OpenGeofiction

Labels

Posted by ADB52 on 12 October 2017 in English (English)

I have a multipolygon named Borgense Park in the east of Utterland. However, the label for the MP appears far away from the actual location - look at http://opengeofiction.net/#map=10/55.6047/46.9116. The westernmost extremity of Borgense Park shows up to the east of Uisteren, yet the label is rendered 60 km to the west, near Rijksbergen. I have previously split the multipolygon, which may have something to do with it. The issue only appears in zoom 10.

Comment from Luciano on 12 October 2017 at 23:51

I looked at this briefly using JOSM and what I can say is that the park's boundary relation is not constructed properly. You have "inner" roles outside, you have "inner" ways crossing "outer" ways, etc. I think when you have a bad relation, you get unpredictable results in the render.

Hide this comment

Comment from ADB52 on 12 October 2017 at 23:55

Oops. Thank you for pointing this out, I'll look at this again.

Hide this comment

Comment from martinum4 on 13 October 2017 at 18:15

Kinda related: The outer ways still contain some attributes, this isn't necessary since they are no closed ways.

Hide this comment

Comment from ADB52 on 14 October 2017 at 05:42

I have addressed the issues highlighted by Luciano, and the stray reference to the Park's name has disappeared from the map. Thank you.

Hide this comment

Leave a comment

Parsed with Markdown

  • Headings

    # Heading
    ## Subheading

  • Unordered list

    * First item
    * Second item

  • Ordered list

    1. First item
    2. Second item

  • Link

    [Text](URL)
  • Image

    ![Alt text](URL)

Login to leave a comment