OpenGeofiction

Map problems

Posted by Yuanls on 20 September 2016 in English (English)

For some reasons zoom levels 17, 18 and 19, the map does not update on standard layer. Zoom 17 has received 1 update in the past 24 hours but zoom 18 and 19 have not been updated at all. So far, I have tried 4 devices and they all have the same problem. The affected area is down below. Zoom out and you will see the difference.

Does anyone see/not see my problem on the map or have the problem yourself?

Things I know about the problem:

  1. It is not a problem caused by my computer. I have tried on multiple devices to the same effect.
  2. It only happens in 'standard' layer. The other layers are fine and display map data properly. The editors in Potlatch and ID show the correct data as well. For some reason, the 'standard' map preview on the map layers menu displays the updated data.
  3. It is a recent occurrence, because edits in the last 24 hours are not displayed, whereas edits I have done before that have shown up.
  4. It is a local occurrence. I mapped a road in Commonia today and it showed up on all zoom levels.
  5. It is possibly a one off issue. I have mapped nearby and all updates have shown.

http://opengeofiction.net/#map=18/52.05349/128.99490

Thanks,

Yuanls

Comment from Thunderbird on 20 September 2016 at 18:52

This has been happening to me for the past few days, I messaged an admin about it and it fixed itself. 24 hours later, it is happening again.

Same on a different computer. I think it is being caused by the new tile renderer. I think the admins know about this and are working on a fix, but I was asked to report any more problems I have.

Hide this comment

Comment from _zM on 21 September 2016 at 18:34

I think OSM has a feature where a tile/an area only gets updated when it has been accessed enough before the tile update. Maybe the original threshold for an update to be scheduled has been left at the default value, which considering the low number of views and edits when compared to OSM is too high for OpenGeofiction.

Hide this comment

Comment from Myrcia on 21 September 2016 at 20:05

It's an odd problem. I edited this area over an hour ago adding a hospital and some warehouses.

http://opengeofiction.net/#map=16/56.3559/19.2691

Some of the edits have appeared on the Histor and Topography layers, the latest edit only appears at zoom level 8 on the T layer!

No sign of the edit on the standard layer.

Hide this comment

Comment from Yuanls on 21 September 2016 at 21:30

Mmm funny...Everyone seems to be having this problem. It has not gone away as I cannot see my recent edits on the map. The edits I did the day before have showed up but apart from that, nothing. Only the Histor layer zoom 18 shows any sign of a update and even then it's not the most recent one.

http://opengeofiction.net/#map=17/52.05247/128.99135

Hide this comment

Comment from admin on 21 September 2016 at 22:32

That was an error in the tile expiry mechanim that I implemented along with setting up the new tile server. I believe I have it fixed now. Please let me know if any problems still occur.

Hide this comment

Comment from Yuanls on 22 September 2016 at 19:59

Everything is normal again-thanks!

Hide this comment

Leave a comment

Parsed with Markdown

  • Headings

    # Heading
    ## Subheading

  • Unordered list

    * First item
    * Second item

  • Ordered list

    1. First item
    2. Second item

  • Link

    [Text](URL)
  • Image

    ![Alt text](URL)

Login to leave a comment