OpenGeofiction

JOSM 18303

Posted by ADB52 on 4 November 2021 in English (English).

Since downloading the latest release of JOSM (18303), it returns bug warnings and does not load a number of plug-ins that are actually fairly useful. I have filed a bugreport to the compilers, but was wondering if anybody else had similar experiences.

Is it worthwhile reverting to an earlier release of JOSM?

Comment from Marcello on 5 November 2021 at 14:25

I have JOSM 18303 (on Win10) - just checked. I run it for some time now. Apart from not getting a good slippy map for downloads (despite following all advice on this site) I have no issues with any plug-in and no bug warnings at all. The only message I get is that I should upgrade to another (OpenWebStart instead of Oracle’s outdated Java WebStart ? whatever - it still works) start-up method.

Which plug-ins give issues?

Marcello.

Comment from ADB52 on 5 November 2021 at 16:26

Apart from the bug being flagged up, I got this message:

JOSM could not find information about the following plug-ins: continuosDownload jaxb reverter measurement FastDraw PicLayer

The plug-ins are not going to be loaded.

Comment from ADB52 on 5 November 2021 at 16:33

The bug also occurs upon accessing Preferences (F12) in JOSM and selecting plugins.

Comment from Marcello on 5 November 2021 at 18:34

Weird…

Continuous Download I have active, as Reverter, Measurement, FastDraw and PictLayer - JAXB not. No issues, no error messages.

Marcello.

Comment from ADB52 on 6 November 2021 at 01:00

Have reinstalled Java, and reinstalled JOSM. Found I had to download the list of extensions and update them. Everything running fine now.


Login to leave a comment